第28节 编译-qt4、qt5、qt6使用vs的编译方法

本文重点

本文要解决的用户使用任意版本的qt和任意版本的vs进行配套的问题当前qt现存的只有qt4、qt5、qt6,各取其最新版本使用vs进行编译。一定要提的是vs的版本不重要,用户不用非要和我的vs版本使用一致,编译方法是一样的。

本文主要解决qt官方没有提供安装包的问题,比如我们使用vs2015,用的很好,但是要用qt4,那qt4没有提供这方面的包呀,怎么办呀?有一点一定要注意:当qt官方已经提供了你所需要的包,你是没有必要自己编译的

本文包含内容

主要包含编译所用到的工具、代码、文档说明,按照这些就可以把想要的包给编译出来,假若不能,则里面还包含了我验证编译时候的视频做为参考

注意: 务必使用浏览器打开,本节是28.7z压缩包:
【击此打开网盘资源链接】

特别注意

滚滚长江东逝水,浪花淘尽英雄,在没有特别的原因下,一定要与时俱进,不能使用特别老的代码却使用特别新的配套,比如用vs2022来做qt4的开发,这个时候vs2022的qt-vs addin还没有出来呢,即便出来能不能用在qt4头上也不好说。我们可以用vs2015开发qt4,可以使用vs2010开发qt4,但是尽量不要使用vs2010开发qt6。这里面随便一个问题都是很难解决的,比如vs2010根本不支持c++14,而qt6要的是C++17,问题是很难办的。

© 版权声明
THE END
喜欢就支持一下吧
点赞0 分享
评论 抢沙发
头像
欢迎您留下宝贵的见解!
提交
头像

昵称

取消
昵称表情代码图片